medium4.6
CVE-2021-21418
Potential XSS injection in the newsletter conditions field
Impact
### Impact An employee can inject javascript in the newsletter condition field that will then be executed on the front office ### Patches The issue has been fixed in 2.6.1
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| composer | prestashop/ps_emailsubscription | < 2.6.1 | 2.6.1 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Prestashop | Ps Emailsubscription | from 2.6.0 before 2.6.1 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/PrestaShop/ps_emailsubscription/commit/664ffb225e2afb4a32640bbedad667dc6e660b70
- https://github.com/PrestaShop/ps_emailsubscription/releases/tag/v2.6.1
- https://github.com/PrestaShop/ps_emailsubscription/security/advisories/GHSA-vwfx-hh3w-fj99
- https://packagist.org/packages/prestashop/ps_emailsubscription
- https://github.com/advisories/GHSA-vwfx-hh3w-fj99
- https://nvd.nist.gov/vuln/detail/CVE-2021-21418