NetSight
medium5.4

CVE-2021-21611

Stored XSS vulnerability in Jenkins on new item page

Impact

Jenkins 2.274 and earlier, LTS 2.263.1 and earlier does not escape display names and IDs of item types shown on the New Item page. This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to specify display names or IDs of item types. As of the publication of this advisory, the Jenkins security team is not aware of any plugins published via the Jenkins project update center that allow doing this. Jenkins 2.275, LTS 2.263.2 escapes display names and IDs of item types shown on the New Item page.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.jenkins-ci.main:jenkins-core<= 2.263.12.263.2

Affected products

VendorProductAffected versions
JenkinsJenkins
through 2.263.1
through 2.274

Weakness classification

References