medium6.5
CVE-2021-21675
CSRF vulnerabilities in Jenkins requests-plugin Plugin
Impact
Jenkins requests-plugin Plugin 2.2.12 and earlier does not require POST requests to request and apply changes, resulting in cross-site request forgery (CSRF) vulnerabilities. These vulnerabilities allow attackers to create requests and/or have administrators apply pending requests, like renaming or deleting jobs, deleting builds, etc. Jenkins requests-plugin Plugin 2.2.13 requires POST requests for the affected HTTP endpoints. This was partially fixed in requests-plugin Plugin 2.2.8 to require POST requests for some of the affected HTTP endpoints, but the endpoint allowing administrators to apply pending requests remained unprotected until 2.2.13.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.jenkins-ci.plugins:requests | <= 2.2.12 | 2.2.13 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Jenkins | Requests | through 2.2.12 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- http://www.openwall.com/lists/oss-security/2021/06/30/1
- https://www.jenkins.io/security/advisory/2021-06-30/#SECURITY-2136%20%281%29
- https://github.com/advisories/GHSA-5frh-wx6v-8m2r
- https://nvd.nist.gov/vuln/detail/CVE-2021-21675
- https://www.jenkins.io/security/advisory/2021-06-30/#SECURITY-2136%20(1)