NetSight
medium6.5

CVE-2021-22051

Request injection in Spring Cloud Gateway

Impact

Applications using Spring Cloud Gateway are vulnerable to specifically crafted requests that could make an extra request on downstream services. Users of affected versions should apply the following mitigation: 3.0.x users should upgrade to 3.0.5+, 2.2.x users should upgrade to 2.2.10.RELEASE or newer.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.springframework.cloud:spring-cloud-gateway>= 3.0.0, < 3.0.53.0.5

Affected products

VendorProductAffected versions
VmwareSpring Cloud Gateway
before 2.2.10
from 3.0.0 before 3.0.5

Weakness classification

References