NetSight
medium4.8

CVE-2021-22132

Insufficiently Protected Credentials in Elasticsearch

Impact

Elasticsearch versions 7.7.0 to 7.10.1 contain an information disclosure flaw in the async search API. Users who execute an async search will improperly store the HTTP headers. An Elasticsearch user with the ability to read the .tasks index could obtain sensitive request headers of other users in the cluster. This issue is fixed in Elasticsearch 7.10.2

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.elasticsearch:elasticsearch>= 7.7.0, < 7.10.27.10.2

Affected products

VendorProductAffected versions
ElasticElasticsearch
from 7.7.0 before 7.10.2
OracleCommunications Cloud Native Core Automated Test Suite
Version 1.8.0

Weakness classification

References