NetSight
high7.5

CVE-2021-23840

Calls to EVP_CipherUpdate, EVP_EncryptUpdate and EVP_DecryptUpdate may overflow the output length argument in some cases where the input length is close to the…

Impact

Calls to EVP_CipherUpdate, EVP_EncryptUpdate and EVP_DecryptUpdate may overflow the output length argument in some cases where the input length is close to the maximum permissable length for an integer on the platform. In such cases the return value from the function call will be 1 (indicating success), but the output length value will be negative. This could cause applications to behave incorrectly or crash. OpenSSL versions 1.1.1i and below are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1j. OpenSSL versions 1.0.2x and below are affected by this issue. However OpenSSL 1.0.2 is out of support and no longer receiving public updates. Premium support customers of OpenSSL 1.0.2 should upgrade to 1.0.2y. Other users should upgrade to 1.1.1j. Fixed in OpenSSL 1.1.1j (Affected 1.1.1-1.1.1i). Fixed in OpenSSL 1.0.2y (Affected 1.0.2-1.0.2x).

Affected products

VendorProductAffected versions
OpensslOpenssl
from 1.0.2 before 1.0.2y
from 1.1.1 before 1.1.1j
DebianDebian Linux
Version 10.0
TenableLog Correlation Engine
before 6.0.8
TenableNessus Network Monitor
Versions 5.11.0, 5.11.1, 5.12.0, 5.12.1, 5.13.0
OracleBusiness Intelligence
Versions 5.5.0.0.0, 5.9.0.0.0, 12.2.1.3.0, 12.2.1.4.0
OracleCommunications Cloud Native Core Policy
Version 1.15.0
OracleEnterprise Manager For Storage Management
Version 13.4.0.0
OracleEnterprise Manager Ops Center
Version 12.4.0.0
OracleGraalvm
Versions 19.3.5, 20.3.1.2, 21.0.0.2
OracleJd Edwards Enterpriseone Tools
before 9.2.6.0
OracleJd Edwards World Security
Version a9.4
OracleMysql Server
before 5.7.33
from 8.0.15 before 8.0.23

Weakness classification

References