high8.8
CVE-2021-25642
Deserialization of Untrusted Data in Apache Hadoop YARN
Impact
ZKConfigurationStore which is optionally used by CapacityScheduler of Apache Hadoop YARN deserializes data obtained from ZooKeeper without validation. An attacker having access to ZooKeeper can run arbitrary commands as YARN user by exploiting this. Users should upgrade to Apache Hadoop 2.10.2, 3.2.4, 3.3.4 or later (containing YARN-11126) if ZKConfigurationStore is used.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.hadoop:hadoop-yarn-server | < 2.10.2 | 2.10.2 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Hadoop | from 2.9.0 before 2.10.2 from 3.0.0 before 3.2.4 from 3.3.0 before 3.3.4 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://lists.apache.org/thread/g6vf2h4wdgzzdgk91mqozhs58wotq150
- https://security.netapp.com/advisory/ntap-20221201-0003/
- https://github.com/advisories/GHSA-rr2m-gffv-mgrj
- https://nvd.nist.gov/vuln/detail/CVE-2021-25642
- https://github.com/apache/hadoop/commit/5e2f4339fadc88f20543915fc9b0aaeaf4f9e7bf