high7.5
CVE-2021-26119
Sandbox escape through template_object in smarty
Impact
Sandbox protection could be bypassed through access to an internal Smarty object that should have been blocked. Sites that rely on [Smarty Security features](https://www.smarty.net/docs/en/advanced.features.tpl) should upgrade as soon as possible. Please upgrade to 3.1.39 or higher.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| composer | smarty/smarty | < 3.1.39 | 3.1.39 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Smarty | Smarty | before 3.1.39 |
| Debian | Debian Linux | Versions 9.0, 10.0, 11.0 |
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/smarty-php/smarty/blob/master/CHANGELOG.md
- https://lists.debian.org/debian-lts-announce/2021/04/msg00004.html
- https://lists.debian.org/debian-lts-announce/2021/04/msg00014.html
- https://security.gentoo.org/glsa/202105-06
- https://www.debian.org/security/2022/dsa-5151
- https://github.com/advisories/GHSA-w5hr-jm4j-9jvq
- https://github.com/smarty-php/smarty/security/advisories/GHSA-w5hr-jm4j-9jvq
- https://nvd.nist.gov/vuln/detail/CVE-2021-26119
- https://srcincite.io/blog/2021/02/18/smarty-template-engine-multiple-sandbox-escape-vulnerabilities.html
- https://github.com/FriendsOfPHP/security-advisories/blob/master/smarty/smarty/CVE-2021-26119.yaml