critical9.8
CVE-2021-26120
PHP Code Injection by malicious function name in smarty
Impact
Template authors could inject php code by choosing a malicous {function} name. Sites that cannot fully trust template authors should update as soon as possible. Please upgrade to 3.1.39 or higher.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| composer | smarty/smarty | < 3.1.39 | 3.1.39 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Smarty | Smarty | before 3.1.39 |
| Debian | Debian Linux | Versions 9.0, 10.0, 11.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/smarty-php/smarty/blob/master/CHANGELOG.md
- https://lists.debian.org/debian-lts-announce/2021/04/msg00004.html
- https://lists.debian.org/debian-lts-announce/2021/04/msg00014.html
- https://security.gentoo.org/glsa/202105-06
- https://www.debian.org/security/2022/dsa-5151
- https://github.com/advisories/GHSA-3rpf-5rqv-689q
- https://github.com/smarty-php/smarty/security/advisories/GHSA-3rpf-5rqv-689q
- https://nvd.nist.gov/vuln/detail/CVE-2021-26120
- https://github.com/smarty-php/smarty/commit/165f1bd4d2eec328cfeaca517a725b46001de838
- https://github.com/smarty-php/smarty/blob/master/CHANGELOG.md#3139---2021-02-17
- https://srcincite.io/blog/2021/02/18/smarty-template-engine-multiple-sandbox-escape-vulnerabilities.html
- https://github.com/FriendsOfPHP/security-advisories/blob/master/smarty/smarty/CVE-2021-26120.yaml