NetSight
high7.5

CVE-2021-26813

markdown2 Regular Expression Denial of Service

Impact

markdown2 >=1.0.1.18, fixed in 2.4.0, is affected by a regular expression denial of service vulnerability. If an attacker provides a malicious string, it can make markdown2 processing difficult or delayed for an extended period of time.

Affected packages

EcosystemPackageAffectedFixed in
pipmarkdown2>= 1.0.1.18, < 2.4.02.4.0

Affected products

VendorProductAffected versions
Markdown2 ProjectMarkdown2
from 1.0.1.18 before 2.4.0
FedoraprojectFedora
Versions 32, 33, 34

Weakness classification

References