high7.1
CVE-2021-27912
XSS vulnerability on asset view
Impact
### Impact Mautic versions before 3.3.4 / 4.0.0 are vulnerable to an inline JS XSS attack when viewing Mautic assets by utilizing inline JS in the title and adding a broken image URL as a remote asset. This can only be leveraged by an authenticated user with permission to create or edit assets. ### Patches Upgrade to 3.3.4 or 4.0.0 ### Workarounds No ### References https://github.com/mautic/mautic/releases/tag/3.3.4 https://github.com/mautic/mautic/releases/tag/4.0.0 ### For more information If you have any questions or comments about this advisory: * Email us at [security@mautic.org](mailto:security@mautic.org)
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| composer | mautic/core | < 3.3.4 | 3.3.4 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Acquia | Mautic | before 3.3.4 Version 4.0.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/mautic/mautic/security/advisories/GHSA-rh5w-82wh-jhr8
- https://github.com/advisories/GHSA-rh5w-82wh-jhr8
- https://nvd.nist.gov/vuln/detail/CVE-2021-27912
- https://github.com/FriendsOfPHP/security-advisories/blob/master/mautic/core/CVE-2021-27912.yaml