NetSight
high7.1Public exploit code

CVE-2021-29447

Wordpress is an open source CMS.

Public exploit code

Working exploit or proof of concept code has been published for this vulnerability. Treat unpatched systems as at risk.

Impact

Wordpress is an open source CMS. A user with the ability to upload files (like an Author) can exploit an XML parsing issue in the Media Library leading to XXE attacks. This requires WordPress installation to be using PHP 8. Access to internal files is possible in a successful XXE attack. This has been patched in WordPress version 5.7.1, along with the older affected versions via a minor release. We strongly recommend you keep auto-updates enabled.

Affected products

VendorProductAffected versions
WordpressWordpress
from 5.6.0 before 5.7.1
DebianDebian Linux
Versions 9.0, 10.0

Weakness classification

References