CVE-2021-29511
Memory over-allocation in evm crate
Impact
### Impact Prior to the patch, when executing specific EVM opcodes related to memory operations that use `evm_core::Memory::copy_large`, the crate can over-allocate memory when it is not needed, making it possible for an attacker to perform denial-of-service attack. ### Patches The flaw was corrected in commit `19ade85`. Users should upgrade to `==0.21.1, ==0.23.1, ==0.24.1, ==0.25.1, >=0.26.1`. ### Workarounds None. Please upgrade your `evm` crate version ### References Fix commit: https://github.com/rust-blockchain/evm/commit/19ade858c430ab13eb562764a870ac9f8506f8dd ### For more information If you have any questions or comments about this advisory: * Open an issue in [evm repo](https://github.com/rust-blockchain/evm) * Email [Wei](mailto:wei@that.world)
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| rust | evm | <= 0.21.0 | 0.21.1 |
| rust | evm-core | <= 0.21.0 | 0.21.1 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Evm Project | Evm | through 0.21.0 Versions 0.22.0, 0.23.0, 0.24.0, 0.25.0, 0.26.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://crates.io/crates/evm
- https://github.com/rust-blockchain/evm/commit/19ade858c430ab13eb562764a870ac9f8506f8dd
- https://github.com/rust-blockchain/evm/security/advisories/GHSA-4jwq-572w-4388
- https://github.com/advisories/GHSA-4jwq-572w-4388
- https://nvd.nist.gov/vuln/detail/CVE-2021-29511