NetSight
high7.5

CVE-2021-29625

XSS in doc_link

Impact

### Impact Users of MySQL, MariaDB, PgSQL and SQLite are affected. XSS is in most cases prevented by strict CSP in all modern browsers. The only exception is when Adminer is using a `pdo_` extension to communicate with the database (it is used if the native extensions are not enabled). In browsers without CSP, Adminer versions 4.6.1 to 4.8.0 are affected. ### Patches Patched by 4043092, included in version [4.8.1](https://github.com/vrana/adminer/releases/tag/v4.8.1). ### Workarounds Do both: * Use browser supporting strict CSP. * Enable the native PHP extensions (e.g. `mysqli`) or disable displaying PHP errors (`display_errors`). ### References https://sourceforge.net/p/adminer/bugs-and-features/797/ ### For more information If you have any questions or comments about this advisory: * Comment at 4043092.

Affected packages

EcosystemPackageAffectedFixed in
composervrana/adminer>= 4.7.8, < 4.8.14.8.1

Affected products

VendorProductAffected versions
AdminerAdminer
from 4.6.1 before 4.8.1

Weakness classification

References