CVE-2021-32668
Cross-Site Scripting in Query Generator & Query View
Impact
> ### Meta > * CVSS: `CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N/E:F/RL:O/RC:C` (4.5) ### Problem Failing to properly encode error messages, the components _QueryGenerator_ and _QueryView_ are vulnerable to both reflected and persistent cross-site scripting. A valid backend user account having administrator privileges is needed to exploit this vulnerability. ### Solution Update to TYPO3 versions 8.7.41 ELTS, 9.5.28, 10.4.18, 11.3.1 that fix the problem described. ### Credits Thanks to Richie Lee who reported this issue and to TYPO3 security team member Oliver Hader who fixed the issue. ### References * [TYPO3-CORE-SA-2021-010](https://typo3.org/security/advisory/typo3-core-sa-2021-010)
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| composer | typo3/cms-core | >= 8.0.0, < 8.7.41 | 8.7.41 |
| composer | typo3/cms | >= 10.0.0, < 10.4.18 | 10.4.18 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Typo3 | Typo3 | from 8.0.0 through 8.7.40 from 9.0.0 through 9.5.28 from 10.0.0 through 10.4.17 from 11.0.0 through 11.3.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/TYPO3/TYPO3.CMS/security/advisories/GHSA-6mh3-j5r5-2379
- https://typo3.org/security/advisory/typo3-core-sa-2021-010
- https://github.com/advisories/GHSA-6mh3-j5r5-2379
- https://nvd.nist.gov/vuln/detail/CVE-2021-32668
- https://github.com/TYPO3/typo3/security/advisories/GHSA-6mh3-j5r5-2379
- https://github.com/FriendsOfPHP/security-advisories/blob/master/typo3/cms-core/CVE-2021-32668.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/typo3/cms/CVE-2021-32668.yaml