NetSight
medium6.4

CVE-2021-32669

Cross-Site Scripting in Backend Grid View

Impact

### Problem Failing to properly encode settings for _backend layouts_, the corresponding grid view is vulnerable to persistent cross-site scripting. A valid backend user account is needed to exploit this vulnerability. ### Solution Update to TYPO3 versions 8.7.41 ELTS, 9.5.28, 10.4.18, 11.3.1 that fix the problem described. ### Credits Thanks to TYPO3 core merger Oliver Bartsch who reported and fixed the issue.

Affected packages

EcosystemPackageAffectedFixed in
composertypo3/cms-core>= 8.0.0, < 8.7.418.7.41
composertypo3/cms>= 10.0.0, < 10.4.1810.4.18

Affected products

VendorProductAffected versions
Typo3Typo3
from 8.0.0 through 8.7.40
from 9.0.0 through 9.5.28
from 10.0.0 through 10.4.17
from 11.0.0 through 11.3.0

Weakness classification

References