medium5.3
CVE-2021-32712
Exposure of Sensitive Information to an Unauthorized Actor
Impact
Shopware is an open source eCommerce platform. Versions prior to 5.6.10 are vulnerable to system information leakage in error handling. Users are recommend to update to version 5.6.10. You can get the update to 5.6.10 regularly via the Auto-Updater or directly via the download overview.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| composer | shopware/shopware | < 5.6.10 | 5.6.10 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Shopware | Shopware | from 5.0.0 before 5.6.10 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-05-2021
- https://github.com/shopware/shopware/commit/dcb24eb5ec757c991b5a4e2ddced379e5820744d
- https://github.com/shopware/shopware/security/advisories/GHSA-9vxv-wpv4-f52p
- https://github.com/advisories/GHSA-qwpp-fgrj-h78q
- https://nvd.nist.gov/vuln/detail/CVE-2021-32712