high8.1
CVE-2021-32800
Nextcloud server is an open source, self hosted personal cloud.
Impact
Nextcloud server is an open source, self hosted personal cloud. In affected versions an attacker is able to bypass Two Factor Authentication in Nextcloud. Thus knowledge of a password, or access to a WebAuthN trusted device of a user was sufficient to gain access to an account. It is recommended that the Nextcloud Server is upgraded to 20.0.12, 21.0.4 or 22.1.0. There are no workaround for this vulnerability.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Nextcloud | Nextcloud Server | before 20.0.12 from 21.0.0 before 21.0.4 from 22.0.0 before 22.1.0 |
Weakness classification
References
- NVD record
- CVE.org record
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-gv5w-8q25-785v
- https://github.com/nextcloud/server/pull/28078
- https://hackerone.com/reports/1271052
- https://security.gentoo.org/glsa/202208-17
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-gv5w-8q25-785v
- https://github.com/nextcloud/server/pull/28078
- https://hackerone.com/reports/1271052
- https://security.gentoo.org/glsa/202208-17