NetSight
high8.8

CVE-2021-33036

User account escalation in Apache Hadoop

Impact

In Apache Hadoop 2.2.0 to 2.10.1, 3.0.0-alpha1 to 3.1.4, 3.2.0 to 3.2.2, and 3.3.0 to 3.3.1, a user who can escalate to yarn user can possibly run arbitrary commands as root user. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.hadoop:hadoop-yarn-server-common>= 2.2.0, < 2.10.22.10.2

Affected products

VendorProductAffected versions
ApacheHadoop
from 2.2.0 before 2.10.2
from 3.0.1 before 3.2.3
from 3.3.0 before 3.3.2
Version 3.0.0

Weakness classification

References