NetSight
medium6.1

CVE-2021-3377

ansi_up cross-site scripting vulnerability

Impact

The npm package ansi_up converts ANSI escape codes into HTML. In ansi_up v4, ANSI escape codes can be used to create HTML hyperlinks. Due to insufficient URL sanitization, this feature is affected by a cross-site scripting (XSS) vulnerability. This issue is fixed in v5.0.0.

Affected packages

EcosystemPackageAffectedFixed in
npmansi_up< 5.0.05.0.0

Affected products

VendorProductAffected versions
Ansi Up ProjectAnsi Up
before 5.0.0

Weakness classification

References