high7.5
CVE-2021-35065
glob-parent 6.0.0 vulnerable to Regular Expression Denial of Service
Impact
glob-parent 6.0.0 is vulnerable to Regular Expression Denial of Service (ReDoS). This issue is fixed in version 6.0.1. This vulnerability is separate from [GHSA-ww39-953v-wcq6](https://github.com/advisories/GHSA-ww39-953v-wcq6).
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | glob-parent | = 6.0.0 | 6.0.1 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Gulpjs | Glob-Parent | from 6.0.0 before 6.0.1 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/gulpjs/glob-parent/commit/3e9f04a3b4349db7e1962d87c9a7398cda51f339
- https://github.com/gulpjs/glob-parent/pull/49
- https://security.snyk.io/vuln/SNYK-JS-GLOBPARENT-1314294
- https://security.netapp.com/advisory/ntap-20230214-0010/
- https://github.com/advisories/GHSA-cj88-88mr-972w
- https://nvd.nist.gov/vuln/detail/CVE-2021-35065
- https://github.com/opensearch-project/OpenSearch-Dashboards/issues/1103
- https://www.mend.io/vulnerability-database/CVE-2021-35065
- https://github.com/gulpjs/glob-parent/releases/tag/v6.0.1
- https://github.com/gulpjs/glob-parent/commit/32f6d52663b7addac38d0dff570d8127edf03f47
- https://security.netapp.com/advisory/ntap-20230214-0010