NetSight
high5.7

CVE-2021-3572

Improper Input Validation in pip

Impact

A flaw was found in python-pip in the way it handled Unicode separators in git references. A remote attacker could possibly use this issue to install a different revision on a repository. The highest threat from this vulnerability is to data integrity. This is fixed in python-pip version 21.1.

Affected packages

EcosystemPackageAffectedFixed in
pippip< 21.121.1

Affected products

VendorProductAffected versions
PypaPip
before 21.1
OracleAgile Product Lifecycle Management
Version 9.3.6
OracleCommunications Cloud Native Core Network Function Cloud Native Environment
Versions 1.10.0, 22.1.0
OracleCommunications Cloud Native Core Policy
Versions 1.15.0, 22.1.3

Weakness classification

References