critical9.8
CVE-2021-37404
Apache Hadoop heap overflow before v2.10.2, v3.2.3, v3.3.2
Impact
There is a potential heap buffer overflow in Apache Hadoop libhdfs native code. Opening a file path provided by user without validation may result in a denial of service or arbitrary code execution. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.hadoop:hadoop-common | >= 3.3.0, < 3.3.2 | 3.3.2 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Hadoop | from 2.9.0 before 2.10.2 from 3.0.0 through 3.1.4 from 3.2.0 before 3.2.3 from 3.3.0 before 3.3.2 |