high7.4
CVE-2021-37633
Discourse is an open source discussion platform.
Impact
Discourse is an open source discussion platform. In versions prior to 2.7.8 rendering of d-popover tooltips can be susceptible to XSS attacks. This vulnerability only affects sites which have modified or disabled Discourse's default Content Security Policy. This issue is patched in the latest `stable` 2.7.8 version of Discourse. As a workaround users may ensure that the Content Security Policy is enabled, and has not been modified in a way which would make it more vulnerable to XSS attacks.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Discourse | Discourse | before 2.7.8 Version 2.8.0 |
Weakness classification
References
- NVD record
- CVE.org record
- https://github.com/discourse/discourse/commit/38199424bc840d2ef002cd1e9bffdbb99191eb47
- https://github.com/discourse/discourse/security/advisories/GHSA-v3v8-3m5w-pjp9
- https://github.com/discourse/discourse/commit/38199424bc840d2ef002cd1e9bffdbb99191eb47
- https://github.com/discourse/discourse/security/advisories/GHSA-v3v8-3m5w-pjp9