medium6.4
CVE-2021-39222
Nextcloud is an open-source, self-hosted productivity platform.
Impact
Nextcloud is an open-source, self-hosted productivity platform. The Nextcloud Talk application was vulnerable to a stored Cross-Site Scripting (XSS) vulnerability. For exploitation, a user would need to right-click on a malicious file and open the file in a new tab. Due the strict Content-Security-Policy shipped with Nextcloud, this issue is not exploitable on modern browsers supporting Content-Security-Policy. It is recommended that the Nextcloud Talk application is upgraded to patched versions 10.0.7, 10.1.4, 11.1.2, 11.2.0 or 12.0.0. As a workaround, use a browser that has support for Content-Security-Policy.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Nextcloud | Talk | before 10.0.7 from 10.1.0 before 10.1.4 from 11.0.0 before 11.1.2 |
Weakness classification
References
- NVD record
- CVE.org record
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-xhxq-f4vg-jw5g
- https://github.com/nextcloud/spreed/pull/542
- https://hackerone.com/reports/1135481
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-xhxq-f4vg-jw5g
- https://github.com/nextcloud/spreed/pull/542
- https://hackerone.com/reports/1135481