NetSight
high7.5

CVE-2021-39229

Apprise vulnerable to regex injection with IFTTT Plugin

Impact

### Impact Anyone _publicly_ hosting the Apprise library and granting them access to the IFTTT notification service. ### Patches Update to Apprise v0.9.5.1 ```bash # Install Apprise v0.9.5.1 from PyPI pip install apprise==0.9.5.1 ``` The patch to the problem was performed [here](https://github.com/caronc/apprise/pull/436/files). ### Workarounds Alternatively, if upgrading is not an option, you can safely remove the following file: - `apprise/plugins/NotifyIFTTT.py` The above will eliminate the ability to use IFTTT, but everything else will work smoothly. ### For more information If you have any questions or comments about this advisory: * Open an issue in [Apprise](https://github.com/caronc/apprise/issues) * Email me at [lead2gold@gmail.com](mailto:lead2gold@gmail.com) ### Additional Credit Github would not allow me to additionally credit **Rasmus Petersen**, but I would like to put that here at the very least - thank you for finding and reporting this issue along with those already credited ## Additional Notes: - Github would not allow me to add/tag the 2 CWE's this issue is applicable to (only CWE-400). The other is: CWE-730 (placed in the title)

Affected packages

EcosystemPackageAffectedFixed in
pipapprise<= 0.9.40.9.5.1

Affected products

VendorProductAffected versions
NuxrefApprise
before 0.9.5.1

Weakness classification

References