NetSight
high7.5

CVE-2021-40110

Denial of Service in Apache James

Impact

In Apache James, using Jazzer fuzzer, we identified that an IMAP user can craft IMAP LIST commands to orchestrate a Denial Of Service using a vulnerable Regular expression. This affected Apache James prior to 3.6.1 We recommend upgrading to Apache James 3.6.1 or higher , which enforce the use of RE2J regular expression engine to execute regex in linear time without back-tracking.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.james:james-server>= 3.1.0, < 3.6.13.6.1

Affected products

VendorProductAffected versions
ApacheJames
before 3.6.1

References