critical9.1
CVE-2021-40525
Path traversal in Apache James
Impact
Apache James ManagedSieve implementation alongside with the file storage for sieve scripts is vulnerable to path traversal, allowing reading and writing any file. This vulnerability had been patched in Apache James 3.6.1 and higher. We recommend the upgrade. Distributed and Cassandra based products are also not impacted.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.james:james-server | < 3.6.1 | 3.6.1 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | James | before 3.6.2 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- http://www.openwall.com/lists/oss-security/2022/01/04/4
- http://www.openwall.com/lists/oss-security/2022/02/07/1
- https://www.openwall.com/lists/oss-security/2022/01/04/4
- https://github.com/advisories/GHSA-c38m-7h53-g9v4
- https://nvd.nist.gov/vuln/detail/CVE-2021-40525