CVE-2021-41134
Stored XSS in Jupyter nbdime
Impact
### Impact Improper handling of user controlled input caused a stored cross-site scripting (XSS) vulnerability. All previous versions of nbdime are affected. ### Patches Security patches will be released for each of the major versions of the nbdime packages since version 1.x of the nbdime python package. #### Python - nbdime 1.x: Patched in v. 1.1.1 - nbdime 2.x: Patched in v. 2.1.1 - nbdime 3.x: Patched in v. 3.1.1 #### npm - nbdime 6.x version: Patched in 6.1.2 - nbdime 5.x version: Patched in 5.0.2 - nbdime-jupyterlab 1.x version: Patched in 1.0.1 - nbdime-jupyterlab 2.x version: Patched in 2.1.1 ### For more information If you have any questions or comments about this advisory email us at [security@ipython.org](mailto:security@ipython.org).
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| pip | nbdime | < 1.1.1 | 1.1.1 |
| npm | nbdime | < 5.0.2 | 5.0.2 |
| npm | nbdime-jupyterlab | < 1.0.1 | 1.0.1 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Jupyter | Nbdime | from 1.0.0 before 1.1.1 from 2.0.0 before 2.1.1 from 3.0.0 through 3.1.1 from 5.0.0 before 5.0.2 from 6.0.0 before 6.1.2 |
| Jupyter | Nbdime-Jupyterlab | from 1.0.0 before 1.0.1 from 2.0.0 before 2.1.1 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/jupyter/nbdime/commit/e44a5cc7677f24b45ebafc756db49058c2f750ea
- https://github.com/jupyter/nbdime/security/advisories/GHSA-p6rw-44q7-3fw4
- https://github.com/advisories/GHSA-p6rw-44q7-3fw4
- https://nvd.nist.gov/vuln/detail/CVE-2021-41134
- https://github.com/pypa/advisory-database/tree/main/vulns/nbdime/PYSEC-2021-428.yaml