NetSight
high8.2

CVE-2021-41164

Advanced Content Filter (ACF) vulnerability allowing to execute JavaScript code using malformed HTML

Impact

### Affected packages The vulnerability has been discovered in the Advanced Content Filter (ACF) module and may affect all plugins used by CKEditor 4. ### Impact A potential vulnerability has been discovered in CKEditor 4 Advanced Content Filter (ACF) core module. The vulnerability allowed to inject malformed HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.17.0. ### Patches The problem has been recognized and patched. The fix will be available in version 4.17.0. ### For more information Email us at security@cksource.com if you have any questions or comments about this advisory. ### Acknowledgements The CKEditor 4 team would like to thank Maurice Dauer ([laytonctf](https://twitter.com/laytonctf)) for recognizing and reporting this vulnerability.

Affected packages

EcosystemPackageAffectedFixed in
npmckeditor4< 4.17.04.17.0

Affected products

VendorProductAffected versions
CkeditorCkeditor
from 4.0 before 4.17.0
DrupalDrupal
from 8.9.0 before 8.9.20
from 9.1.0 before 9.1.14
from 9.2.0 before 9.2.9
OracleBanking Apis
from 18.1 through 18.3
Versions 19.1, 19.2, 20.1, 21.1
OracleBanking Digital Experience
from 18.1 through 18.3
Versions 19.1, 19.2, 20.1, 21.1
OracleAgile Product Lifecycle Management
Version 9.3.6
OracleApplication Express
before 22.1
OracleCommerce Guided Search
Version 11.3.2
OraclePeoplesoft Enterprise Peopletools
Versions 8.58, 8.59
OracleWebcenter Portal
Versions 12.2.1.3.0, 12.2.1.4.0
FedoraprojectFedora
Versions 36, 37

Weakness classification

References