NetSight
high8.2

CVE-2021-41165

CKEditor4 is an open source WYSIWYG HTML editor.

Impact

CKEditor4 is an open source WYSIWYG HTML editor. In affected version a vulnerability has been discovered in the core HTML processing module and may affect all plugins used by CKEditor 4. The vulnerability allowed to inject malformed comments HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.17.0. The problem has been recognized and patched. The fix will be available in version 4.17.0.

Affected products

VendorProductAffected versions
CkeditorCkeditor
before 4.17.0
DrupalDrupal
from 8.9.0 before 8.9.20
from 9.1.0 before 9.1.14
from 9.2.0 before 9.2.9
OracleAgile Product Lifecycle Management
Version 9.3.6
OracleApplication Express
before 22.1
OracleBanking Apis
from 18.1 through 18.3
Versions 19.1, 19.2, 20.1, 21.1
OracleBanking Digital Experience
from 18.1 through 18.3
Versions 19.1, 19.2, 20.1, 21.1
OracleCommerce Guided Search
Version 11.3.2
OraclePeoplesoft Enterprise Peopletools
Versions 8.58, 8.59
OracleWebcenter Portal
Versions 12.2.1.3.0, 12.2.1.4.0

Weakness classification

References