high8.1
CVE-2021-41177
Nextcloud is an open-source, self-hosted productivity platform.
Impact
Nextcloud is an open-source, self-hosted productivity platform. Prior to versions 20.0.13, 21.0.5, and 22.2.0, Nextcloud Server did not implement a database backend for rate-limiting purposes. Any component of Nextcloud using rate-limits (as as `AnonRateThrottle` or `UserRateThrottle`) was thus not rate limited on instances not having a memory cache backend configured. In the case of a default installation, this would notably include the rate-limits on the two factor codes. It is recommended that the Nextcloud Server be upgraded to 20.0.13, 21.0.5, or 22.2.0. As a workaround, enable a memory cache backend in `config.php`.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Nextcloud | Nextcloud Server | before 20.0.13 from 21.0.0 before 21.0.5 from 22.0.0 before 22.2.0 |
Weakness classification
References
- NVD record
- CVE.org record
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-fj39-4qx4-m3f2
- https://github.com/nextcloud/server/pull/28728
- https://hackerone.com/reports/1265709
- https://security.gentoo.org/glsa/202208-17
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-fj39-4qx4-m3f2
- https://github.com/nextcloud/server/pull/28728
- https://hackerone.com/reports/1265709
- https://security.gentoo.org/glsa/202208-17