NetSight
medium6.5

CVE-2021-41184

XSS in the `of` option of the `.position()` util in jquery-ui

Impact

### Impact Accepting the value of the `of` option of the [`.position()`](https://api.jqueryui.com/position/) util from untrusted sources may execute untrusted code. For example, invoking the following code: ```js $( "#element" ).position( { my: "left top", at: "right bottom", of: "<img onerror='doEvilThing()' src='/404' />", collision: "none" } ); ``` will call the `doEvilThing()` function. ### Patches The issue is fixed in jQuery UI 1.13.0. Any string value passed to the `of` option is now treated as a CSS selector. ### Workarounds A workaround is to not accept the value of the `of` option from untrusted sources. ### For more information If you have any questions or comments about this advisory, search for a relevant issue in [the jQuery UI repo](https://github.com/jquery/jquery-ui/issues). If you don't find an answer, open a new issue.

Affected packages

EcosystemPackageAffectedFixed in
npmjquery-ui< 1.13.01.13.0
mavenorg.webjars.npm:jquery-ui< 1.13.01.13.0
nugetjQuery.UI.Combined< 1.13.01.13.0
rubygemsjquery-ui-rails< 7.0.07.0.0

Affected products

VendorProductAffected versions
JqueryuiJquery Ui
before 1.13.0
FedoraprojectFedora
Versions 33, 34, 35, 36
NetappH300s Firmware
All versions
NetappH500s Firmware
All versions
NetappH700s Firmware
All versions
NetappH300e Firmware
All versions
NetappH500e Firmware
All versions
NetappH700e Firmware
All versions
NetappH410s Firmware
All versions
NetappH410c Firmware
All versions
DrupalDrupal
from 7.0 before 7.86
from 9.2.0 before 9.2.11
from 9.3.0 before 9.3.3
TenableTenable.Sc
before 5.21.0

Weakness classification

References