CVE-2021-41186
Fluentd collects events from various data sources and writes them to files to help unify logging infrastructure.
Impact
Fluentd collects events from various data sources and writes them to files to help unify logging infrastructure. The parser_apache2 plugin in Fluentd v0.14.14 to v1.14.1 suffers from a regular expression denial of service (ReDoS) vulnerability. A broken apache log with a certain pattern of string can spend too much time in a regular expression, resulting in the potential for a DoS attack. This issue is patched in version 1.14.2 There are two workarounds available. Either don't use parser_apache2 for parsing logs (which cannot guarantee generated by Apache), or put patched version of parser_apache2.rb into /etc/fluent/plugin directory (or any other directories specified by the environment variable `FLUENT_PLUGIN` or `--plugin` option of fluentd).
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Fluentd | Fluentd | from 0.14.14 through 1.14.1 |
Weakness classification
References
- NVD record
- CVE.org record
- https://github.com/fluent/fluentd/blob/master/CHANGELOG.md#v1142
- https://github.com/fluent/fluentd/security/advisories/GHSA-hwhf-64mh-r662
- https://github.com/github/securitylab-vulnerabilities/blob/52dc4a2a828c6dc24231967c2937ad92038184a9/vendor_reports/GHSL-2021-102-fluent-fluentd.md
- https://github.com/fluent/fluentd/blob/master/CHANGELOG.md#v1142
- https://github.com/fluent/fluentd/security/advisories/GHSA-hwhf-64mh-r662
- https://github.com/github/securitylab-vulnerabilities/blob/52dc4a2a828c6dc24231967c2937ad92038184a9/vendor_reports/GHSL-2021-102-fluent-fluentd.md