NetSight
critical9.8

CVE-2021-41303

Apache Shiro vulnerable to a specially crafted HTTP request causing an authentication bypass

Impact

Apache Shiro before 1.8.0, when using Apache Shiro with Spring Boot, a specially crafted HTTP request may cause an authentication bypass. Users should update to Apache Shiro 1.8.0.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.shiro:shiro-core< 1.8.01.8.0

Affected products

VendorProductAffected versions
ApacheShiro
before 1.8.0
OracleFinancial Services Crime And Compliance Management Studio
Versions 8.0.8.2.0, 8.0.8.3.0

Weakness classification

References