NetSight
medium5.4

CVE-2021-4231

Angular vulnerable to Cross-site Scripting

Impact

A vulnerability was found in Angular up to 11.0.4/11.1.0-next.2. It has been classified as problematic. Affected is the handling of comments. The manipulation leads to cross site scripting. It is possible to launch the attack remotely but it might require an authentication first. Upgrading to version 10.2.5, 11.0.5 or 11.1.0-next.3 is advised to to address this issue.

Affected packages

EcosystemPackageAffectedFixed in
npm@angular/core>= 11.1.0-next.0, <= 11.1.0-next.211.1.0-next.3

Affected products

VendorProductAffected versions
AngularAngular
Version 11.1.0
AngularjsAngularjs
before 11.0.5

Weakness classification

References