high7.5
CVE-2021-4306
terminal-kit Inefficient Regular Expression Complexity vulnerability
Impact
A vulnerability classified as problematic has been found in cronvel terminal-kit up to 2.1.7. Affected is an unknown function. The manipulation leads to inefficient regular expression complexity. Upgrading to version 2.1.8 can address this issue. The name of the patch is a2e446cc3927b559d0281683feb9b821e83b758c. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217620.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | terminal-kit | < 2.1.8 | 2.1.8 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Terminal-Kit Project | Terminal-Kit | before 2.1.8 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/cronvel/terminal-kit/commit/a2e446cc3927b559d0281683feb9b821e83b758c
- https://github.com/cronvel/terminal-kit/releases/tag/v2.1.8
- https://vuldb.com/?ctiid.217620
- https://vuldb.com/?id.217620
- https://github.com/advisories/GHSA-wxgh-8gmr-3qh3
- https://nvd.nist.gov/vuln/detail/CVE-2021-4306