NetSight
critical9.8

CVE-2021-43608

DBAL 3 SQL Injection Security Vulnerability

Impact

We have released a new version Doctrine DBAL 3.1.4 that fixes a critical SQL injection vulnerability in the LIMIT clause generation API provided by the Platform abstraction. We advise everyone using Doctrine DBAL 3.0.0 up to 3.1.3 to upgrade to 3.1.4 immediately. The vulnerability can happen when unsanitized input is passed to many APIs in Doctrine DBAL and ORM that ultimately end up calling `AbstractPlatform::modifyLimitQuery`. As a workaround you can cast all limit and offset parameters to integers before passing them to Doctrine APIs. This vulnerability has been assigned [CVE-2021-43608](https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-43608).

Affected packages

EcosystemPackageAffectedFixed in
composerdoctrine/dbal>= 3.0.0, < 3.1.43.1.4

Affected products

VendorProductAffected versions
Doctrine-ProjectDatabase Abstraction Layer
from 3.0.0 before 3.1.4

Weakness classification

References