NetSight
high7.6

CVE-2021-43785

Cross-Site Scripting Vulnerability in @joeattardi/emoji-button

Impact

### Impact There are two vectors for XSS attacks with versions of @joeattardi/emoji-button before 4.6.2: - A URL for a custom emoji - An i18n string In both of these cases, a value can be crafted such that it can insert a `script` tag into the page and execute malicious code. ### Patches This vulnerability is fixed starting in version 4.6.2. This is resolved by properly escaping strings that are inserted into the HTML document. ### Workarounds There is no workaround other than upgrading to a non-vulnerable version. ### Credit This issue was discovered by GitHub team member [@erik-krogh (Erik Krogh Kristensen)](https://github.com/erik-krogh) and was reported by the GitHub Security Lab team.

Affected packages

EcosystemPackageAffectedFixed in
npm@joeattardi/emoji-button< 4.6.24.6.2

Affected products

VendorProductAffected versions
Emoji Button ProjectEmoji Button
before 4.6.2

Weakness classification

References