NetSight
high7.2

CVE-2021-43861

Incorrect sanitisation function leads to `XSS` in mermaid

Impact

### Impact Malicious diagrams can contain javascript code that can be run at diagram readers machines. ### Patches The users should upgrade to version 8.13.8 ### Workarounds You need to upgrade in order to avoid this issue.

Affected packages

EcosystemPackageAffectedFixed in
npmmermaid< 8.13.88.13.8

Affected products

VendorProductAffected versions
Mermaid ProjectMermaid
before 8.13.8

Weakness classification

References