NetSight
critical9.1

CVE-2021-44140

Incorrect Default Permissions in Apache JSPWiki

Impact

Remote attackers may delete arbitrary files in a system hosting a JSPWiki instance, versions up to 2.11.0.M8, by using a carefuly crafted http request on logout, given that those files are reachable to the user running the JSPWiki instance. Apache JSPWiki users should upgrade to 2.11.0 or later.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.jspwiki:jspwiki-main< 2.11.02.11.0

Affected products

VendorProductAffected versions
ApacheJspwiki
before 2.11.0

Weakness classification

References