NetSight
critical10.0Known exploitedPublic exploit code

CVE-2021-44228

Remote code injection in Log4j

Exploited in the wild

This vulnerability is on a Known Exploited Vulnerabilities catalogue, added 2021-12-10. Federal due date: 2021-12-24.

For all affected software assets for which updates exist, the only acceptable remediation actions are: 1) Apply updates; OR 2) remove affected assets from agency networks. Temporary mitigations using one of the measures provided at https://www.cisa.gov/uscert/ed-22-02-apache-log4j-recommended-mitigation-measures are only acceptable until updates are available.

Public exploit code

Working exploit or proof of concept code has been published for this vulnerability. Treat unpatched systems as at risk.

Impact

# Summary Log4j versions prior to 2.16.0 are subject to a remote code execution vulnerability via the ldap JNDI parser. As per [Apache's Log4j security guide](https://logging.apache.org/log4j/2.x/security.html): Apache Log4j2 <=2.14.1 JNDI features used in configuration, log messages, and parameters do not protect against attacker controlled LDAP and other JNDI related endpoints. An attacker who can control log messages or log message parameters can execute arbitrary code loaded from LDAP servers when message lookup substitution is enabled. From log4j 2.16.0, this behavior has been disabled by default. Log4j version 2.15.0 contained an earlier fix for the vulnerability, but that patch did not disable attacker-controlled JNDI lookups in all situations. For more information, see the `Updated advice for version 2.16.0` section of this advisory. # Impact Logging untrusted or user controlled data with a vulnerable version of Log4J may result in Remote Code Execution (RCE) against your application. This includes untrusted data included in logged errors such as exception traces, authentication failures, and other unexpected vectors of user controlled input. # Affected versions Any Log4J version prior to v2.15.0 is affected to this specific issue. The v1 branch of Log4J which is considered End Of Life (EOL) is vulnerable to other RCE vectors so the recommendation is to still update to 2.16.0 where possible. ## Security releases Additional backports of this fix have been made available in versions 2.3.1, 2.12.2, and 2.12.3 ## Affected packages Only the `org.apache.logging.log4j:log4j-core` package is directly affected by this vulnerability. The `org.apache.logging.log4j:log4j-api` should be kept at the same version as the `org.apache.logging.log4j:log4j-core` package to ensure compatability if in use. # Remediation Advice ## Updated advice for version 2.16.0 The Apache Logging Services team provided updated mitigation advice upon the release of version 2.16.0, which [disables JNDI by default and completely removes support for message lookups](https://logging.apache.org/log4j/2.x/changes-report.html#a2.16.0). Even in version 2.15.0, lookups used in layouts to provide specific pieces of context information will still recursively resolve, possibly triggering JNDI lookups. This problem is being tracked as [CVE-2021-45046](https://nvd.nist.gov/vuln/detail/CVE-2021-45046). More information is available on the [GitHub Security Advisory for CVE-2021-45046](https://github.com/advisories/GHSA-7rjr-3q55-vv33). Users who want to avoid attacker-controlled JNDI lookups but cannot upgrade to 2.16.0 must [ensure that no such lookups resolve to attacker-provided data and ensure that the the JndiLookup class is not loaded](https://issues.apache.org/jira/browse/LOG4J2-3221). Please note that Log4J v1 is End Of Life (EOL) and will not receive patches for this issue. Log4J v1 is also vulnerable to other RCE vectors and we recommend you migrate to Log4J 2.16.0 where possible.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.logging.log4j:log4j-core>= 2.13.0, < 2.15.02.15.0
mavencom.guicedee.services:log4j-core<= 1.2.1.2-jre17none recorded
mavenorg.xbib.elasticsearch:log4j= 6.3.2.1none recorded
mavenuk.co.nichesolutions.logging.log4j:log4j-core= 2.6.3-CUSTOMnone recorded
mavenorg.ops4j.pax.logging:pax-logging-log4j2>= 1.8.0, < 1.9.21.9.2

Affected products

VendorProductAffected versions
Siemens6bk1602-0aa12-0tp0 Firmware
before 2.7.0
Siemens6bk1602-0aa22-0tp0 Firmware
before 2.7.0
Siemens6bk1602-0aa32-0tp0 Firmware
before 2.7.0
Siemens6bk1602-0aa42-0tp0 Firmware
before 2.7.0
Siemens6bk1602-0aa52-0tp0 Firmware
before 2.7.0
ApacheLog4j
from 2.0.1 before 2.3.1
from 2.4.0 before 2.12.2
from 2.13.0 before 2.15.0
Version 2.0
SiemensSppa-T3000 Ses3000 Firmware
All versions
SiemensCapital
before 2019.1
Version 2019.1
SiemensComos
before 10.4.2
SiemensDesigo Cc Advanced Reports
Versions 3.0, 4.0, 4.1, 4.2, 5.0, 5.1
SiemensDesigo Cc Info Center
Versions 5.0, 5.1
SiemensE-Car Operation Center
before 2021-12-13

Weakness classification

References