NetSight
high7.8

CVE-2021-44730

snapd 2.54.2 did not properly validate the location of the snap-confine binary.

Impact

snapd 2.54.2 did not properly validate the location of the snap-confine binary. A local attacker who can hardlink this binary to another location to cause snap-confine to execute other arbitrary binaries and hence gain privilege escalation. Fixed in snapd versions 2.54.3+18.04, 2.54.3+20.04 and 2.54.3+21.10.1

Affected products

VendorProductAffected versions
CanonicalSnapd
through 2.54.2
CanonicalUbuntu Linux
Versions 18.04, 20.04, 21.10
FedoraprojectFedora
Versions 34, 35
DebianDebian Linux
Versions 10.0, 11.0

Weakness classification

References