NetSight
high7.7

CVE-2022-21647

Deserialization of Untrusted Data in Codeigniter4

Impact

### Impact Deserialization of Untrusted Data was found in the `old()` function in CodeIgniter4. Remote attackers may inject auto-loadable arbitrary objects with this vulnerability, and possibly execute existing PHP code on the server. We are aware of a working exploit, which can lead to SQL injection. ### Patches Upgrade to v4.1.6 or later. ### Workarounds Do not use: - `old()` and form_helper - `RedirectResponse::withInput()` and `redirect()->withInput()` ### References - [PHP Object Injection | OWASP](https://owasp.org/www-community/vulnerabilities/PHP_Object_Injection) ### For more information If you have any questions or comments about this advisory: * Open an issue in [codeigniter4/CodeIgniter4](https://github.com/codeigniter4/CodeIgniter4/issues) * Email us at [SECURITY.md](https://github.com/codeigniter4/CodeIgniter4/blob/develop/SECURITY.md)

Affected packages

EcosystemPackageAffectedFixed in
composercodeigniter4/framework< 4.1.64.1.6

Affected products

VendorProductAffected versions
CodeigniterCodeigniter
from 4.0.0 before 4.1.6

Weakness classification

References