NetSight
high8.0Public exploit code

CVE-2022-21661

WordPress is a free and open-source content management system written in PHP and paired with a MariaDB database.

Public exploit code

Working exploit or proof of concept code has been published for this vulnerability. Treat unpatched systems as at risk.

Impact

WordPress is a free and open-source content management system written in PHP and paired with a MariaDB database. Due to improper sanitization in WP_Query, there can be cases where SQL injection is possible through plugins or themes that use it in a certain way. This has been patched in WordPress version 5.8.3. Older affected versions are also fixed via security release, that go back till 3.7.37. We strongly recommend that you keep auto-updates enabled. There are no known workarounds for this vulnerability.

Affected products

VendorProductAffected versions
WordpressWordpress
from 3.7 before 3.7.37
from 3.8 before 3.8.37
from 3.9 before 3.9.35
from 4.0 before 4.0.34
from 4.1 before 4.1.34
from 4.2 before 4.2.31
FedoraprojectFedora
Versions 34, 35
DebianDebian Linux
Versions 9.0, 10.0, 11.0

Weakness classification

References