medium6.8
CVE-2022-21687
Command injection in gh-ost
Impact
Gh-ost version <= 1.1.2 allows users to inject DSN strings via the `-database` parameter. This is a low severity vulnerability as the attacker must have access to the target host or trick an administrator into executing a malicious `gh-ost` command on a host running `gh-ost`, plus network access from host running `gh-ost` to the attack's malicious MySQL server. ### Impact This issue may lead to arbitrary local file read. ### Patches Fixed in 1.1.3+. ### Workarounds None ### References - https://advisory.dw1.io/51 ### For more information If you have any questions or comments about this advisory: * Open an issue in [github/gh-ost](http://github.com/github/gh-ost)
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| go | github.com/github/gh-ost | < 1.1.3 | 1.1.3 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Github | Gh-Ost | before 1.1.3 |