medium5.3
CVE-2022-23505
Authentication Bypass for passport-wsfed-saml2
Impact
# Overview A remote attacker can bypass WSFed authentication on a website using passport-wsfed-saml2. A successful attack requires that the attacker is in possession of an arbitrary IDP signed WSFed assertion. Depending on the IDP used, fully unauthenticated attacks (e.g without access to a valid user) might also be feasible if generation of a signed message can be triggered. # Am I affected? You are affected if you are using WSFed protocol with the passport-wsfed-saml2 library versions < 4.6.3. SAML2 protocol is not affected. # How do I fix it? Upgrade the library to version 4.6.3. # Will the fix impact my users? No, the fix will not impact your users.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | passport-wsfed-saml2 | < 4.6.3 | 4.6.3 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Auth0 | Passport-Wsfed-Saml2 | through 4.6.2 |