NetSight
medium6.1

CVE-2022-23518

Improper neutralization of data URIs may allow XSS in rails-html-sanitizer

Impact

## Summary rails-html-sanitizer `>= 1.0.3, < 1.4.4` is vulnerable to cross-site scripting via data URIs when used in combination with Loofah `>= 2.1.0`. ## Mitigation Upgrade to rails-html-sanitizer `>= 1.4.4`. ## Severity The maintainers have evaluated this as [Medium Severity 6.1](https://www.first.org/cvss/calculator/3.0#CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N). ## References - [CWE - CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') (4.9)](https://cwe.mitre.org/data/definitions/79.html) - [SVG MIME Type (image/svg+xml) is misleading to developers · Issue #266 · w3c/svgwg](https://github.com/w3c/svgwg/issues/266) - https://github.com/rails/rails-html-sanitizer/issues/135 - https://hackerone.com/reports/1694173 ## Credit This vulnerability was independently reported by Maciej Piechota (@haqpl) and Mrinmoy Das (@goromlagche).

Affected packages

EcosystemPackageAffectedFixed in
rubygemsrails-html-sanitizer>= 1.0.3, < 1.4.41.4.4

Affected products

VendorProductAffected versions
RubyonrailsRails Html Sanitizers
from 1.0.3 before 1.4.4
DebianDebian Linux
Version 10.0
Loofah ProjectLoofah
from 2.1.0 before 2.19.1

Weakness classification

References