NetSight
medium4.3

CVE-2022-23708

Elasticsearch privilege escalation

Impact

A flaw was discovered in Elasticsearch 7.17.0’s upgrade assistant, in which upgrading from version 6.x to 7.x would disable the in-built protections on the security index, allowing authenticated users with “*” index permissions access to this index. Users running a cluster on an affected version that had previously been upgraded from 6.x, should upgrade to 7.17.1. Users that are planning to upgrade from 6.x should not perform an upgrade from 6.x to versions 7.16 through 7.17.0 and should use 7.17.1+ for upgrades from 6.x.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.elasticsearch:elasticsearch>= 7.16.0, < 7.17.17.17.1

Affected products

VendorProductAffected versions
ElasticElasticsearch
from 7.16.0 before 7.17.1

Weakness classification

References