critical9.4
CVE-2022-24711
Remote CLI Command Execution Vulnerability in CodeIgniter4
Impact
### Impact This vulnerability allows attackers to execute CLI routes via HTTP request. ### Patches Upgrade to v4.1.9 or later. ### Workarounds None. ### For more information If you have any questions or comments about this advisory: * Open an issue in [codeigniter4/CodeIgniter4](https://github.com/codeigniter4/CodeIgniter4/issues) * Email us at [SECURITY.md](https://github.com/codeigniter4/CodeIgniter4/blob/develop/SECURITY.md)
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| composer | codeigniter4/framework | < 4.1.9 | 4.1.9 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Codeigniter | Codeigniter | from 4.0.0 before 4.1.9 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/codeigniter4/CodeIgniter4/commit/202f41ad522ba1d414b9d9c35aba1cb0c156b781
- https://github.com/codeigniter4/CodeIgniter4/security/advisories/GHSA-xjp4-6w75-qrj7
- https://github.com/advisories/GHSA-xjp4-6w75-qrj7
- https://nvd.nist.gov/vuln/detail/CVE-2022-24711
- https://github.com/FriendsOfPHP/security-advisories/blob/master/codeigniter4/framework/CVE-2022-24711.yaml